Could not reconnect to all network drives on win 7 error

I've found several others having the same problem as I on this and other forums but no answer yet.

I have a home network that includes a win server 2008 with a NAS thecus n7700 which are both connected to my linksys router. I connect to my NAS by using the \\thecus\raid in windows explorer. On all my other PC's I access it as my "Z" drive. This has worked fine through XP, Vista and even Windows 7 installations on the same PC (discussed below) for some time. But now whenever I boot up my system with Windows 7 I get the

"Could not reconnect all network drives"

error every time I boot.

When I click on the "Z:" drive through Windows Explorer or a link on the desktop W7 pro asks me for a userid and password. I type in my username and password which the Thecus requires as its a share on the NAS and does require a login, which I can not disable. When I do, my sharedNAS connects asZ: (I refer this as a manual connection for the rest of this post). Thereafter all my apps can use, see, change files on z:\ . All is golden until my next reboot.

It's important for me that the system automatically connect because a dozen or so of my apps routinely interact with my "Z:" drive. For example I use the program Second Copy to automatically backup several directories and drives across my network to my Thecus NAS on Z:. That app won't work until z: is connected. My iTunes library is situated on my NAS. iTunes won't see my iTunes library and gives error messages until I manually connect the Z: drive and on and on and on from app to app. My Z:\ drive is my data repository for all my devices.

Here's the rub. When I first installed Win 7 RC (on the exact same PC) I installed it as an upgrade to my then current Vista x64 installation. After that upgrade, I had no problem. That Z: drive auto connected on bootup just as it had when I was running Vista on the same PC and just as it had when I ran XP before on the same PC.

Subsequently I chose to do a fresh Win 7 PRo install on the exact same PC that I had previously installed the Win 7 RC as a Vista x64 upgrade. That's when this problem arose.

Despite dozens of hours of research and tinkering I have NOT been able to get my shared Z:\ NAS drive hosted off a router to automatically connect when I boot up. I have changed NOTHING on the windows server 2008 or the router. I have changed nothing on Thecus NAS device (though I did try rebooting it and removing the map network drive letter on win 7 to reset / update directory permissions - this did nothing). My other networked Vista/XP PCs continue to access it as their Z: drive without incident. It is only my clean-install Win 7 Pro that cannot automatically connect to that shared network drive on boot.

What is truly strange is that on this EXACT same PC the share worked flawlessly (as always) after an upgrade from Vista x64, but when I did a fresh/clean install on the EXACT same PC, the problem raised its head.

- All PC's on my network are on the same workgroup.
- The problem persists whether or not I have a homegroup activated
- I have no problems accessing shared drives BETWEEN PCs running Win 7
- I have no problem accessing the shared Thecus NAS device on the XP PC from other XP/Vista PCs
- all pcs are behind a NAT router so firewalls are turned off
- no anti virus software is running on any PC (not that anti-virus software ever caused an issue here before)
- I have tried changing most of the Advanced Sharing Settings in:

Start --> network and sharing center --> change advanced sharing settings

including turning on and off 'password protected sharing'
also i did the following: Start - > Run (search area) -> netplwiz {enter}
uncheck the checkbox "users
must enter a username and password to use this computer"

- When I mapped my network drive to Z:\ I did it using the proper '\\server\sharename' naming convention
- I note that when I click on the "Browse..." button my networked XP server does not show up as an available network device (though I can still connect to it by manually typing \\server\drobo
- I, of course, always check the 'Reconnect at logon' checkbox on the "Map Network Drive" dialogue box
- Whether or not I check the "Connect using different credentials' checkbox on the "Map Network Drive" dialogue box makes no difference.
- Under the 'Computer' item on the left side of Windows Explorer, the Z:\ drive shows up (before manual connection) with a red x through it.
- I note that under the 'Network' item on the left side of Windows Explorer, only Win 7 RC PCs show up even though Win 7 RC shows all network PC's even XP PCs in the Network Map
- Clicking on the 'Remember my credentials' checkbox on the "Enter Network Password" screen when I manually connect makes no difference - WB7 clearly doesn't remember them.
- NOTE: I do NOT login with the same userid and password on the server and on my WB7 machine. I never had to before (including when WB7 on this PC was an upgrade from Vista) so I can't imagine that that is the problem. Note, all other PCs on my network access the shared NAS from ANY userid on any other PC

Control Panel --> Network and Internet --> Network Map,

(after manually connecting N: by clicking on it, that is)

anyone else getting this problem, how did you get fix it?
I've tried everything I can think of...

Tags: 7, windows

Views: 569

Reply to This

Replies to This Discussion

And this is why I don't jmp the wagon when a new OS comes out. First two years of release is more of a "Gamma testing" period.
I have the exact same issue and very close to the same set up. Have tried all the same steps. Don't know what to do here...
So, this is what I discovered-
Mapping Network Drives in Windows Vista/Windows 7
Mapping network drives in Vista/Windows 7 has an added complication. Briefly, the default security method that Vista/Windows 7 use to connect in this way is incompatible with Carleton's servers. Vista & 7 have a compatible option available to it, but it has to be selected from a setting buried deep in the registry. To change this setting:
1. Select one of the the following paths (depending on how your Control Panel appears):
Vista Default: Start > Control Panel > System and Maintenance > Administrative Tools > Local Security Policy
Classic View: Start > Control Panel > Administrative Tools > Local Security Policy
If you don't see Local Security Policy there: then you can run it from the Command Prompt: Start > Programs > Accessories > Command Prompt
In the command window, type %systemroot%\system32\secpol.msc /s
2. In the new window, select: Local Policies > Security Options
3. Look for the following entry: Network Security: LAN Manager authentication level
4. Change the value
from: Send NTLMv2 response only
to: Send LM and NTLM - use NTLMv2 session security if negotiated
The change should take effect immediately, after which you can map drives using the same method as Windows XP.

If you still aren't able to get to Local Security Policy, then just download this registry key to your computer, double-click it to import, then restart your computer. Then you should be able to map drives using the same method as Windows XP.


Bad news, Windows 7 Home Premium does not have LSP or the ability to access it. You need Professional, Ultimate or Enterprise.

RSS

© 2014   Created by Chris Pirillo.

Badges  |  Report an Issue  |  Terms of Service